Recent content https://ledgersmb.org/index.php/ en Features https://ledgersmb.org/index.php/content/features <span class="field field--name-title field--type-string field--label-hidden">Features</span> <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>LedgerSMB is an open source <a href="https://en.wikipedia.org/wiki/Enterprise_resource_planning">ERP</a> program which offers businesses the ability to manage their operations, track invoices and their payments, inventory, and more in an integrated way - from a single application. <span style="line-height: 1.5;">Benefits of using LedgerSMB include:</span></p> <ul> <li>Short ramp-up times due to a simple, powerful user interface</li> <li>Easy integration with other business applications via open architecture</li> <li>Customizability supporting your competitive advantage:<br /> <span style="line-height: 1.5;">Build the software around your business, not the other way around</span></li> <li>Open community of <a href="http://ledgersmb.org/topic/commercial-support">consultants</a> and service providers</li> </ul> <h1>Core functionality</h1> <p>The core functionality is provided by a series of built-in modules, listed below. Additional functionality or changes in application behaviour can be achieved by installing add-ons. See the next section for more on add-ons.</p> <ul> <li><strong>General Ledger and Journal Entry</strong><br /> Manage your accounts, transfer money between them, and get a picture of the general financial health of your business, through double-entry accounting.</li> <li><strong>Sales</strong><br /> Track customers, quotations, sales orders, and invoices.</li> <li><strong>Purchasing</strong><br /> Track vendors, purchase orders, and invoices.</li> <li><strong>Multiple currencies</strong><br /> Enter your transaction, invoices and payments in different currencies using different conversion rates.</li> <li><strong>Contact Management</strong><br /> Track customer/vendor orders and relationships to your business.</li> <li><strong>Cash Management</strong><br /> Handle cash in and cash out. Write checks, track receipts, and reconcile with bank statements.</li> <li><strong>Time tracking</strong><br /> Track time and generate invoices from billable hours.</li> <li><strong>Fixed Assets</strong><br /> Track and manage fixed assets, their depreciation and disposal.</li> <li><strong>Inventory Management and Light Manufacturing</strong><br /> Track goods and services, and assemblies of these.</li> <li><strong>Reporting</strong></li> <li><strong>Budgeting</strong><br /> Track budgets by project and/or department, and run variance reports.</li> </ul> <h1>Add-ons</h1> <p>Some functionality isn't suitable for inclusion in the standard application. Functionality available as add-ons in 1.3, has been integrated in 1.4 and 1.5. The current list of add-ons is therefore empty.</p> </div> <span class="field field--name-uid field--type-entity-reference field--label-hidden"><span>Anonymous (not verified)</span></span> <span class="field field--name-created field--type-created field--label-hidden">Sat, 10/15/2011 - 03:47</span> <section class="field field--name-comment-node-page field--type-comment field--label-hidden comment-wrapper"> </section> Sat, 15 Oct 2011 10:47:30 +0000 Anonymous 145 at https://ledgersmb.org Open Source ERP: accounting, invoicing and more https://ledgersmb.org/index.php/content/open-source-erp-accounting-invoicing-and-more <span class="field field--name-title field--type-string field--label-hidden">Open Source ERP: accounting, invoicing and more</span> <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><h1>Mission</h1> <p><a href="/statement-direction-ledgersmb">The LedgerSMB project</a> provides small and mid-size businesses with open source <a href="https://en.wikipedia.org/wiki/Accounting_software">accounting software</a>: integrating invoicing, order processing, quotations and more (<a href="https://en.wikipedia.org/wiki/Enterprise_resource_planning">ERP</a>). LedgerSMB aims to provide a strong (multi-currency accounting) basis to build your business on -- without vendor lock-in.</p> <h1><span style="line-height: 36.4000015258789px;">Features</span></h1> <ul> <li>Sales (Invoices, Orders, Quotations)</li> <li>Receivables &amp; Payables</li> <li>General ledger</li> <li>Inventory management</li> <li>Fixed asset accounting &amp; depreciation</li> <li>Profit &amp; cost centers, departments, projects</li> <li>Output documents in PDF, HTML, CSV, Office formats</li> <li>Mail documents (e.g. invoices) from within the application</li> <li>Translatable to your language (comes with 45 languages)</li> <li><a href="http://ledgersmb.org/features">and more</a></li> </ul> <p>The fact that LedgerSMB is <a href="https://opensource.org/osd">open source</a> - meaning that the source code is freely available - makes it even more customizable and flexible.</p> <h1 style="line-height: 36.4px;">Use-cases</h1> <h2>By industry</h2> <p>While LedgerSMB will generally work in any industry for its basic accounting functionalities, it is known to have been deployed in the following types of businesses:</p> <ul> <li>Communications<br /> e.g. VOIP services</li> <li>Factoring<br /> i.e. invoicing of others</li> <li>(IT) Services<br /> e.g. Website design, IT Support, hourly services</li> <li>Financial services<br /> e.g. Investment firms</li> <li>Rental<br /> e.g. Housing rental, IT Hosting</li> <li>Retail<br /> e.g. Sewing necessities</li> <li>Trade<br /> e.g. Trading pet foods</li> </ul> <p>Many of these applications include integration with domain-specific applications to perform specific business functions.</p> <p>Next to the ones listed above, various manufacturing setups have been deployed, ranging from standard (batch based) mass production, to make-to-order one-time product configurations. The latter being supported by a custom developed product configuration plugin.</p> <h2>By country</h2> <p>Although the nature of open source projects makes it hard to know where our software is being used; however, the project is aware of installations in the <span class="mx_MTextBody mx_EventTile_content"><span class="mx_EventTile_body" dir="auto">US, Canada, EU (Netherlands, Hungary, Estonia, United Kingdom), Indonesia, Myanmar, Philippines, Hong Kong, Malaysia, Australia, Barbados and Colombia.</span></span></p> <p><span class="mx_MTextBody mx_EventTile_content"><span class="mx_EventTile_body" dir="auto">The software can run in a different language for each user. Also: documents (invoices, orders, etc) can be produced in selectable languages, different from the user's language.</span></span></p> <h1>Contributions</h1> <p>The project welcomes any and all contributions. With lots of areas which would benefit from more attention, we like to invite newcomers to read our <a data-entity-substitution="canonical" data-entity-type="node" data-entity-uuid="c8075f26-dba4-48f6-bf53-3702c418dbdd" href="/index.php/content/community-guide" title="Community guide">community guidelines</a> and start out simple. Good (and helpful!) starting points are <a data-entity-substitution="canonical" data-entity-type="node" data-entity-uuid="3fc7f2b0-0844-4ae0-868b-90b968686d0f" href="/index.php/community-guide/community-guide/translating" title="Translating">translation contributions</a> as well as reviewing our (beginners) documentation.</p> <h1 style="line-height: 36.4px;">Current versions</h1> <p>Our current stable version is <a href="https://github.com/ledgersmb/LedgerSMB/tree/1.8"><em><strong>1.8</strong></em></a> - initially released on Sep 04, 2020. This release has a wide variety of improvements and code cleanups: it features faster loading of the menu, fixed migrations from 1.2, the ability to upload a logo into the database and include it in printed documents and much more... More details about this release can be found in the <a data-entity-substitution="canonical" data-entity-type="node" data-entity-uuid="ff891fb8-f65b-486c-a374-1510c5c24975" href="/index.php/content/19-release-notes" title="1.9 release notes">release notes</a>. This release will see its End-Of-Life for community support at <strong>Sep 04, 2022</strong>.</p> <p>Our current old-stable version is <em><a href="https://github.com/ledgersmb/LedgerSMB/tree/1.7"><strong>1.7</strong></a></em> - initially released on Oct 04, 2019. This release focusses on improved support for foreign currency transactions, lifting the restriction of a single rate per currency per day; UI improved by showing both the functional and foreign currency amounts. Additionally, a lot of work has been spent on increasing the application stability through more rigorous testing and code cleanup. A full summary of the changes since 1.6 can be found in the release announcement. More details on this release can be found in the <a href="https://ledgersmb.org/content/17-release-notes">release notes</a>. This release will see its End-Of-Life for community support at <strong>Oct 04, 2022</strong>.</p> <h2>Pre-release version</h2> <p>There currently are no pre-release versions.</p> <h1>Older versions</h1> <p>Version <strong><em>1.6</em></strong> has been declared End-Of-Life on 2021, June 10th (released on June 10 2018). With 33 patch releases, we consider this version highly stable. Although there are more patch releases for 1.6 than thee are for 1.5, their size is on average smaller, attesting to the project's promise of delivering increasing software quality.</p> <p>Version <em><strong>1.5</strong></em> has been declared End-Of-Life on 2019, Dec 23rd (released on 2016-12-23). With 30 patch releases, we consider this version highly stable. We believe that the lower number of patch releases over a similar life-span as 1.4 is an indication of better stability of the initial 1.5.0 release. We conclude that the project is delivering on its promise of increasing stability of minor releases.</p> <p>Version <em><strong>1.4</strong></em> has been declared End-Of-Life on 2017, Sep 15th (released on 2014-09-15). With 42 patch releases, we consider this version highly stable.</p> <p>Version <em><strong>1.3</strong></em> has been declared End-Of-Life on 2015, Dec 23rd (released on 2011-10-11). With a total of 48 patch releases since the initial release in October 2011, we consider this version highly stable.</p> <p>Although their use is highly discouraged for both security reasons and data stability issues, older versions are still available for <a href="http://download.ledgersmb.org/f/Releases/">download</a>. When using LedgerSMB versions 1.2 or earlier, you should to do so in only in a highly restricted network environment.</p> <p>It's project policy to provide at least 24 months of community support for every 1.x release series; note that this policy was updated: releases 1.7 and earlier had 36 months community support. As such, there's no community support available for 1.5 or earlier LedgerSMB versions. Vendors may be willing to provide <a href="http://ledgersmb.org/topic/commercial-support">support or migration services</a>.</p> <h1><a id="history" name="history"></a>History</h1> <p>LedgerSMB began in 2006 as a fork of the popular general ledger software package called <a class="ext" href="http://www.sql-ledger.com/" style="text-decoration: underline; ">SQL-Ledger</a> largely written and maintained by Dieter Simader since 1999. Versions 1.2 and earlier are heavily based on SQL-Ledger's code.<br /> As of 1.3 our codebase is quickly moving away from what we inherited.<br /> As of 1.5 our User Interface has moved to Dojo Javascript libraries providing a more dynamic feel.<br /> Some of the improvements that we've made to the code base so far include:</p> <ul> <li>Enhanced security</li> <li>More reports</li> <li>Better data integrity controls</li> <li>More code quality control measures</li> <li>Major code size reduction while growing functionality</li> <li>Unit testing Infrastructure to help ensure once an issue is fixed it stays fixed</li> <li>BDD (headless automated browser) Testing infrastructure</li> <li>A very large number of tests against both testing frameworks</li> </ul> <p>Travel in our history with Internet Archive and <a href="http://wayback.archive.org/web/*/http://www.ledgersmb.org">WayBackMachine</a>.</p> </div> <span class="field field--name-uid field--type-entity-reference field--label-hidden"><span>Chris Travers</span></span> <span class="field field--name-created field--type-created field--label-hidden">Sat, 03/17/2007 - 23:08</span> <section class="field field--name-comment-node-page field--type-comment field--label-hidden comment-wrapper"> </section> Sun, 18 Mar 2007 06:08:41 +0000 Chris Travers 153 at https://ledgersmb.org Can I use the webservices using curl? https://ledgersmb.org/index.php/faq/can-i-use-webservices-using-curl <span class="field field--name-title field--type-string field--label-hidden">Can I use the webservices using curl?</span> <div class="clearfix text-formatted field field--name-field-detailed-question field--type-text-long field--label-hidden field__item"><p>I'm writing this script in bash that I want to use to invoke functionality in LedgerSMB. Can I use curl and the webservices API to do that?</p> </div> <span class="field field--name-uid field--type-entity-reference field--label-hidden"><span>ehu</span></span> <span class="field field--name-created field--type-created field--label-hidden">Sun, 06/13/2021 - 13:35</span> <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>Yes you can. In order to do so, you must first create a valid session for your follow-up requests by authenticating:</p> <pre> $ curl -c cookie-jar.txt -H 'Content-Type: application/json' \ -d '{"login": "&lt;your-user&gt;", "password": "&lt;your-password&gt;", "company": "&lt;your-company&gt;"}' \ https://example.org/login.pl?action=authenticate</pre> <p>The request above creates a file called "cookie-jar.txt" in the current directory which - after successful authentication - contains the authentication cookie to be used for follow-up requests. To use it, use curl's -b parameter:</p> <pre> $ curl -b cookie-jar.txt -c cookie-jar.txt -H 'Content-Type: application/json' \ -d @request-body.json https://example.org/erp/api/v0/invoices/</pre> <p>Note that the use of curl's "-d" parameter implies that a POST request is issued. The presence of the at-sign in "@request-body.json" tells curl to read the request body from the file 'request-body.json'. When you decide not to use 'curl', but issue these requests from programming language, please make sure to issue POST requests.</p> </div> <div class="field field--name-field-component field--type-list-string field--label-above"> <div class="field__label">Component</div> <div class="field__item">Base</div> </div> <div class="field field--name-field-release field--type-entity-reference field--label-above"> <div class="field__label">Release</div> <div class="field__items"> <div class="field__item"><a href="/index.php/taxonomy/term/149" hreflang="en">1.9</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/150" hreflang="en">1.10</a></div> </div> </div> <div class="field field--name-field-faq-category field--type-entity-reference field--label-above"> <div class="field__label">FAQ Category</div> <div class="field__item"><a href="/index.php/faq-categories/integration" hreflang="en">Integration</a></div> </div> <section class="field field--name-comment-node-faq field--type-comment field--label-hidden comment-wrapper"> </section> Sun, 13 Jun 2021 20:35:25 +0000 ehu 526 at https://ledgersmb.org System requirements https://ledgersmb.org/index.php/content/system-requirements <span class="field field--name-title field--type-string field--label-hidden">System requirements</span> <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><h1>Hardware requirements</h1> <p>The hardware required to run LedgerSMB greatly depends on the number of users. However, with a small number of users (up to 10 or so), a 32bit server with 512MB to 1GB of memory (including Linux Server OS) and just a few hundred MB of storage (excluding OS) should be enough to get good performance.<br /> For a 64bit server, you probably need 1GB to 2GB of memory, but otherwise the requirements are the same.</p> <h1>Operating system requirements</h1> <p>LedgerSMB runs on Linux/Unix (for the Server) and any platform with a compatible Web Browser (for the Client).<br /> Platforms that have known-compatible browsers are Linux, Windows, MacOS, most smart phones and tablets should also work although the current UI requires a large screen for optimum usability. (Minimal size: 9.7" tablet in landscape mode.)</p> <p>Unix includes all flavours (variants) of Linux including</p> <ul> <li>Debian</li> <li>Mint</li> <li>Ubuntu</li> <li>RedHat</li> <li>Fedora</li> <li>BSD</li> <li>MacOS / OS X</li> <li>and many more</li> </ul> <h2>MS Windows</h2> <ul> <li>While in the past the server would run on Windows as well, this is currently not tested and expected to break.</li> <li>LedgerSMB has a client / server architecture, so while it is often better to run the server on Linux, this will not stop you from running the clients on windows. In fact this is a common situation and is fully supported.</li> </ul> <p>For more information on running on windows please look at the FAQ item <a href="http://ledgersmb.org/faq/can-i-use-ledgersmb-ms-windows">Can I use LedgerSMB on MS Windows?</a></p> <h1>Software requirements (client)</h1> <p>On the client, LedgerSMB requires a compatible browser. As of version 1.9, the development team keeps track of which exact browser capabilities that are used by LedgerSMB to determine which browser versions are supported and which ones are not. On versions 1.8 and older, the indicated minimum requirement is based on the indication provided by the <a href="https://dojotoolkit.org/reference-guide/1.10/releasenotes/1.10.html#user-agent-support">Dojo Toolkit development team</a> in combination with a rough impact estimation of additional capabilities used by LedgerSMB's own JavaScript.</p> <table border="1" cellpadding="1" cellspacing="1"> <caption>Minimum browser versions supported by LedgerSMB (by version)</caption> <thead> <tr> <th rowspan="2" scope="row"> </th> <th class="text-align-center" colspan="2" rowspan="2" scope="col">Chrome</th> <th class="text-align-center" colspan="2" scope="col">Safari</th> <th class="text-align-center" rowspan="2" scope="col">Firefox</th> <th class="text-align-center" rowspan="2" scope="col">Opera</th> <th class="text-align-center" rowspan="2" scope="col">Edge</th> <th class="text-align-center" rowspan="2" scope="col">Internet<br /> Explorer</th> </tr> <tr> <th class="text-align-center" scope="col">Desktop</th> <th class="text-align-center" scope="col">Mobile</th> </tr> </thead> <tbody> <tr> <th scope="row">1.4</th> <td class="text-align-center" colspan="2" rowspan="5">13</td> <td class="text-align-center" colspan="2" rowspan="5">5</td> <td class="text-align-center" colspan="1" rowspan="5">3.6</td> <td class="text-align-center" colspan="1" rowspan="5">10.50</td> <td class="text-align-center" colspan="1" rowspan="5">(all)</td> <td class="text-align-center">8</td> </tr> <tr> <th scope="row">1.5</th> <td class="text-align-center" colspan="1" rowspan="3">10</td> </tr> <tr> <th scope="row">1.6</th> </tr> <tr> <th scope="row">1.7</th> </tr> <tr> <th scope="row">1.8</th> <td class="text-align-center">n/a</td> </tr> <tr> <th scope="row">1.9</th> <td class="text-align-center" colspan="2" rowspan="1">2017-09 (61)</td> <td class="text-align-center">2017-03 (10.1)</td> <td class="text-align-center">2017-03 (10.3)</td> <td class="text-align-center">2018-05 (60)</td> <td class="text-align-center">2017-09 (48)</td> <td class="text-align-center">2017-10 (16)</td> <td class="text-align-center">n/a</td> </tr> <tr> <th scope="row">1.10</th> <td class="text-align-center" colspan="2" rowspan="1">2017-09 (61)</td> <td class="text-align-center">2017-03 (10.1)</td> <td class="text-align-center">2017-03 (10.3)</td> <td class="text-align-center">2018-05 (60)</td> <td class="text-align-center">2017-09 (48)</td> <td class="text-align-center">2017-10 (16)</td> <td class="text-align-center">n/a</td> </tr> </tbody> </table> <p>Please note that on Android, browsers are being pushed to end-user devices so that most devices always have the latest Chrome, FireFox or Opera browser. To that extent, there's little point in mentioning the oldest supported version. If you would be interested to know anyway: the desktop versions of the same browsers are a good indication of support of the required capabilities on mobile as well.</p> <h1>Software requirements (server)</h1> <p>LedgerSMB builds upon technology of some very widely used - proven - projects:</p> <ul> <li><a href="https://www.postgresql.org/">PostgreSQL</a> - the enterprise level quality open source database</li> <li>Starman (perl webserver)</li> <li><a href="http://www.perl.org/">Perl</a> - the programming language of the web</li> <li>(Xe)LaTeX - the typesetting language (optional)<br /> This is used by the Templating system to generate PDF and Postscript output for printing, email or saving to disk</li> </ul> <p>Each version of LedgerSMB has its own requirements. The high level requirements are listed in the table below.</p> <table border="1" cellpadding="1" cellspacing="1"> <caption>Requirements by LedgerSMB version</caption> <thead> <tr> <th rowspan="2" scope="row"> </th> <th rowspan="2" scope="col">Status</th> <th rowspan="2" scope="col">PostgreSQL</th> <th rowspan="2" scope="col">Application server<br /> / HTTP server</th> <th rowspan="2" scope="col">Perl</th> <th class="text-align-center" colspan="2" scope="col">PDF</th> </tr> <tr> <th class="text-align-center" scope="col">PDF</th> <th class="text-align-center" scope="col"><abbr title="PDF for Archiving, also known as ISO 19005-1">PDF/A</abbr></th> </tr> </thead> <tbody> <tr> <th scope="row">1.4</th> <td colspan="1" rowspan="3">End-Of-Life<br /> (no community support)</td> <td>8.4 and up</td> <td>Apache 1.3 and up</td> <td colspan="1" rowspan="2">5.10 and up</td> <td rowspan="7">LaTeX for ASCII or<br /> XeLaTeX for UTF-8 characters</td> <td rowspan="7">LuaTeX with pdfx TeX package</td> </tr> <tr> <th scope="row">1.5</th> <td colspan="1" rowspan="3">9.4 and up</td> <td colspan="1" rowspan="6">Starman*</td> </tr> <tr> <th scope="row">1.6</th> <td>5.14 and up</td> </tr> <tr> <th scope="row">1.7</th> <td>old stable</td> <td>5.18 and up</td> </tr> <tr> <th scope="row">1.8</th> <td>stable</td> <td>9.6 and up</td> <td>5.20 and up</td> </tr> <tr> <th scope="row">1.9</th> <td>testing</td> <td>10 and up</td> <td>5.24 and up</td> </tr> <tr> <th scope="row">1.10</th> <td>unstable</td> <td>13 and up</td> <td>5.32 and up</td> </tr> </tbody> </table> <p>* While Starman is the prefered (and tested) webserver for 1.5 and newer.<br />       It should <strong>ALWAYS</strong> be reverse proxied as HTTPS using Apache/Nginx or possibly other HTTP servers.<br />       It may be possible to run directly from another HTTPD server, but this is not a supported configuration.<br />       Also, in most cases there are performance gains to be had by using Starman.</p> <h2>Perl module dependencies</h2> <p>The Perl module dependencies are listed in the <a href="https://github.com/ledgersmb/LedgerSMB/blob/master/cpanfile">'cpanfile' in the root of the project tree</a>. Many distributions include at least <em>some</em> of the dependencies in their repositories, so that it <em><strong>shouldn't</strong></em> be necessary to install <em><strong>all</strong></em> the dependencies listed in the cpanfile from <a href="http://www.cpan.org/">CPAN</a>.</p> <p>During the installation process, the availability of the "cpanm" binary is required.</p> </div> <span class="field field--name-uid field--type-entity-reference field--label-hidden"><span>ehu</span></span> <span class="field field--name-created field--type-created field--label-hidden">Sat, 06/30/2012 - 05:58</span> <div class="field field--name-field-topic field--type-entity-reference field--label-above"> <div class="field__label">Topic</div> <div class="field__items"> <div class="field__item"><a href="/index.php/faq-categories/installation" hreflang="en">Installation</a></div> <div class="field__item"><a href="/index.php/topic/installation" hreflang="en">Installation</a></div> </div> </div> <section class="field field--name-comment-node-page field--type-comment field--label-hidden comment-wrapper"> </section> Sat, 30 Jun 2012 12:58:33 +0000 ehu 164 at https://ledgersmb.org 1.9 release notes https://ledgersmb.org/index.php/content/19-release-notes <span class="field field--name-title field--type-string field--label-hidden">1.9 release notes</span> <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><h1>What's new and notable in LedgerSMB 1.9</h1> <ul> <li>Customer/Vendor drop-down on invoices searchable</li> <li>E-mailed documents stored in the database</li> <li>Searching open invoices for payment by customer/vendor name</li> <li>A new command line application for administrative tasks and automation</li> <li>"GIFI" selections are now hidden when no GIFI is configured</li> <li>Option to create opening or closing balance report</li> <li>Mailing of aging reports</li> <li>'Update' no longer clobbers saved invoices and transactions</li> <li>Optimized HTML and JavaScript responses for faster page loading</li> </ul> <h1>New features</h1> <h2>Customer/Vendor drop-down on invoices (and transactions) searchable</h2> <p>The customer/vendor selection drop-down on AR/AP transactions and invoices has been replaced with an input element which filters available names based on input entered. Before, there was a regular drop-down listing a fixed list of choices. However, when the number of customers gets too big, that's an impractical way of selecting a customer or vendor. Therefore, another input selection mechanism was available where a regular textbox was used to search the desired customer/vendor on 'Update'. This new feature provides good middle ground. If your database is configured to use the regular textbox, entering a high enough number in the "Max per drop-down" setting in the "System &gt; Defaults" screen enables this new functionality (for drop-downs no larger than the specified number of items).</p> <h2>E-mailed documents stored in the database</h2> <p>Invoices and aging reports, when mailed, are now stored in the database. This provides the opportunity to download the documents for inspection from the e-mail entry screen as well as that it serves as an archive of what has been sent to whom. In the past, there was no way to check emails having been sent, other than by including oneself as a Bcc recipient.</p> <h2>Searching open invoices for payment by customer/vendor name</h2> <p>.</p> <h2>A new command line application for administrative tasks and automation</h2> <p>.</p> <h2>"GIFI" selections are now hidden when no GIFI is configured</h2> <p>Most installations don't need GIFI codes for their accounts: it's a canadian coding system required by law to support government reporting. Often, it's being used for alternative reporting classifications for companies outside of Canada. When neither is the case, GIFI would be offered as a search delimiter in many places. Now, GIFI input boxes are being suppressed when no GIFI is configured for the company. As soon as a single GIFI code is configured, the codes will show in the UI again.</p> <h2>Option to create opening or closing balance report</h2> <p>Before this release, there was an option to either include or ignore "year ends" when running the balance sheet report. This type of input was deemed too technical: the actual question the application was trying to ask was whether the user is trying to run an opening or a closing balance at the given date. Exactly <em>how</em> the application achieves that, is an implementation detail that involves date calculus and in-/exclusion of "year ends". These technicalities have now been hidden from the user.</p> <h1>Notable changes</h1> <h2>Mailing of aging reports</h2> <p>Versions of LedgerSMB up to and including 1.4 had a function to mail aging reports to customers. With the release of 1.5, this functionality was accidentally regressed: forgotten to be implemented in the refactoring of the last reporting functionalities being moved to "the new reporting framework". This was in 2016. Finally, this function has been <em><strong>added back</strong></em> into LedgerSMB as of the 1.9 release.</p> <h2>'Update' no longer clobbers saved invoices and transactions</h2> <p>For a long time the function has existed in LedgerSMB whereby a user can save a transaction in order to store it and either work on it later, or post it later. The function has been broken for quite a while due to the fact that clicking "Update" on a saved transaction (or invoice) would restore the transaction to its saved state - undoing all work done on the saved transaction to prepare it for posting. Technically, it was a complex task to prevent the entered data from being reverted to the original state, but the 1.9 release finally fixes this issue which was filed in 2015.</p> <h2>Optimized HTML and JavaScript responses for faster page loading</h2> <p>Extensive research has been performed on what determined the response times for HTML pages. Many small code changes were implemented to speed up page response times, shaving off some 30% of the response time of a huge GL search report.</p> <p>Additionally, a lot of research went into finding ways to reduce the size of the JavaScript files being used by the application as well as reducing the number of requests to load these files into the browser. As a result, LedgerSMB now uses <a href="https://webpack.js.org/guides/installation/">Webpack</a> to process JavaScript source files from our own project, <a href="https://dojotoolkit.org/">Dojo Toolkit</a> and JS dependencies from NPM. Further research to increase JS performance is on-going, even after the 1.9 release, all in terms of number of dependencies, code size and execution speed.</p> <h1>Other user-visible changes</h1> <ul> <li>The list of country names in the preferences screen is now translated to the selected language</li> <li>The invoice entry screen now links to the customer/vendor screen with the customer/vendor preselected</li> <li>Faster calculation of the balance sheet report</li> <li>Faster population of the list of currencies (applies to all screens with a currency drop-down)</li> <li>All non-required drop-downs now contain an empty value that can be selected to undo the selection of a non-empty value</li> <li>Orders and invoices show history: e.g. saving, posting, printing and mailing</li> <li>Improved error reporting and handling on failure with Print buttons</li> <li>E-mailed invoices generated based on the data in the database instead of the data visible (and editable!) on-screen ensuring consistency between invoice and stored data</li> </ul> <h1>Known problems</h1> <p>.</p> </div> <span class="field field--name-uid field--type-entity-reference field--label-hidden"><span>ehu</span></span> <span class="field field--name-created field--type-created field--label-hidden">Sun, 12/15/2019 - 04:28</span> <div class="field field--name-field-topic field--type-entity-reference field--label-above"> <div class="field__label">Topic</div> <div class="field__items"> <div class="field__item"><a href="/index.php/taxonomy/term/145" hreflang="en">release notes</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/148" hreflang="en">Draft</a></div> </div> </div> <div class="field field--name-field-release field--type-entity-reference field--label-above"> <div class="field__label">Release</div> <div class="field__items"> <div class="field__item"><a href="/index.php/taxonomy/term/149" hreflang="en">1.9</a></div> </div> </div> <section class="field field--name-comment-node-article field--type-comment field--label-hidden comment-wrapper"> </section> Sun, 15 Dec 2019 12:28:36 +0000 ehu 451 at https://ledgersmb.org Which versions of PostgreSQL does LedgerSMB support? https://ledgersmb.org/index.php/faq/which-versions-postgresql-does-ledgersmb-support <span class="field field--name-title field--type-string field--label-hidden">Which versions of PostgreSQL does LedgerSMB support?</span> <span class="field field--name-uid field--type-entity-reference field--label-hidden"><span>Chris Travers</span></span> <span class="field field--name-created field--type-created field--label-hidden">Wed, 12/13/2006 - 16:52</span> <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>The table below lists the compatibility of LedgerSMB versions with PostgreSQL versions. Products for which support has ceased due to End-of-Life date being reached are not listed and should not be used.</p> <table border="1" cellpadding="1" cellspacing="1" style="width: 600px; "> <caption style=""><strong>PostgreSQL compatibility</strong></caption> <thead style=""> <tr style=""> <th scope="row" style="">PostgreSQL</th> <th class="text-align-center" scope="col">1.7</th> <th class="text-align-center" scope="col">1.8</th> <th class="text-align-center" scope="col">1.9</th> <th class="text-align-center" scope="col">1.10 (planned)</th> </tr> </thead> <tbody style=""> <tr> <th scope="row" style="">9.3</th> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">9.4 </th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">9.5</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">9.6</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">10</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">11</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">12</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">13</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> </tr> </tbody> </table> <p>Versions 1.6 and earlier are not in this table due to the fact that they're past <a href="http://ledgersmb.org/faq/support/which-versions-do-you-support">End of Life</a>.</p> </div> <div class="field field--name-field-release field--type-entity-reference field--label-above"> <div class="field__label">Release</div> <div class="field__items"> <div class="field__item"><a href="/index.php/release/all-versions" hreflang="en">All Versions</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/146" hreflang="en">1.7</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/147" hreflang="en">1.8</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/149" hreflang="en">1.9</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/150" hreflang="en">1.10</a></div> </div> </div> <div class="field field--name-field-faq-category field--type-entity-reference field--label-above"> <div class="field__label">FAQ Category</div> <div class="field__item"><a href="/index.php/faq-categories/installation" hreflang="en">Installation</a></div> </div> <div class="field field--name-field-topic field--type-entity-reference field--label-above"> <div class="field__label">Topic</div> <div class="field__items"> <div class="field__item"><a href="/index.php/topics/compatibility" hreflang="en">Compatibility</a></div> </div> </div> <section class="field field--name-comment-node-faq field--type-comment field--label-hidden comment-wrapper"> </section> Thu, 14 Dec 2006 00:52:45 +0000 Chris Travers 34 at https://ledgersmb.org Which versions of Perl does LedgerSMB support? https://ledgersmb.org/index.php/faq/which-versions-perl-does-ledgersmb-support <span class="field field--name-title field--type-string field--label-hidden">Which versions of Perl does LedgerSMB support?</span> <span class="field field--name-uid field--type-entity-reference field--label-hidden"><span>ehu</span></span> <span class="field field--name-created field--type-created field--label-hidden">Sun, 09/04/2016 - 08:03</span> <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>The table below lists the compatibility of LedgerSMB versions with Perl versions. Products for which support has ceased due to End-of-Life date being reached are not listed and should not be used.</p> <table border="1" cellpadding="1" cellspacing="1"> <caption style=""><strong>Perl compatibility</strong></caption> <thead style=""> <tr style=""> <th scope="row" style="">Perl</th> <th class="text-align-center" scope="col">1.7</th> <th class="text-align-center" scope="col">1.8</th> <th class="text-align-center" scope="col">1.9</th> <th class="text-align-center" scope="col"> <p>1.10<br /> (planned)</p> </th> </tr> </thead> <tbody style=""> <tr style=""> <th scope="row" style="">5.10</th> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr style=""> <th scope="row" style="">5.12</th> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr style=""> <th scope="row" style="">5.14</th> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">5.16</th> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">5.18</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">5.20</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">5.22</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">5.24</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">5.26</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">5.28</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">5.30</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; ">no</td> </tr> <tr> <th scope="row" style="">5.32</th> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> <td style="text-align: center; "><strong>yes</strong></td> </tr> </tbody> </table> <p>Versions 1.6 and earlier are not in this table due to the fact that they're past <a href="http://ledgersmb.org/faq/support/which-versions-do-you-support">End of Life</a>.</p> </div> <div class="field field--name-field-release field--type-entity-reference field--label-above"> <div class="field__label">Release</div> <div class="field__items"> <div class="field__item"><a href="/index.php/release/all-versions" hreflang="en">All Versions</a></div> <div class="field__item"><a href="/index.php/release/10" hreflang="en">1.0</a></div> <div class="field__item"><a href="/index.php/release/11" hreflang="en">1.1</a></div> <div class="field__item"><a href="/index.php/release/12" hreflang="en">1.2</a></div> <div class="field__item"><a href="/index.php/release/13" hreflang="en">1.3</a></div> <div class="field__item"><a href="/index.php/release/14" hreflang="en">1.4</a></div> <div class="field__item"><a href="/index.php/release/15" hreflang="en">1.5</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/142" hreflang="en">1.6</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/146" hreflang="en">1.7</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/147" hreflang="en">1.8</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/149" hreflang="en">1.9</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/150" hreflang="en">1.10</a></div> </div> </div> <div class="field field--name-field-faq-category field--type-entity-reference field--label-above"> <div class="field__label">FAQ Category</div> <div class="field__item"><a href="/index.php/faq-categories/installation" hreflang="en">Installation</a></div> </div> <section class="field field--name-comment-node-faq field--type-comment field--label-hidden comment-wrapper"> </section> Sun, 04 Sep 2016 15:03:24 +0000 ehu 358 at https://ledgersmb.org Which versions do you support? https://ledgersmb.org/index.php/faq/which-versions-do-you-support <span class="field field--name-title field--type-string field--label-hidden">Which versions do you support?</span> <span class="field field--name-uid field--type-entity-reference field--label-hidden"><span>ehu</span></span> <span class="field field--name-created field--type-created field--label-hidden">Sun, 12/30/2012 - 03:17</span> <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><h1>Active support</h1> <p>Versions 1.7 and higher are under active development and are supported by the community. Planned end-of-life dates for current releases are:</p> <ul> <li>1.7: Planned End-of-life date: 2022-10-04 (released: 2019-10-04)</li> <li>1.8: Planned End-of-life date: 2022-09-04 (to be released 2020-09-04)</li> <li>1.9: Planned End-of-life date: TBD (based on release date; to be released)</li> </ul> <h1 style="line-height: 36px;">End of life</h1> <p>If you're looking for help on how to use EOL-ed versions, please try mailing <a href="https://lists.ledgersmb.org/mailman/listinfo/users">the users mailing</a> list.<br /> If you're looking for someone to create bugfixes, please check with one of the parties providing <a href="http://ledgersmb.org/topic/commercial-support">commercial support</a> or for less urgent fixes <a href="https://github.com/ledgersmb/LedgerSMB/issues">LedgerSMB Issues</a></p> <p>Version 1.6 has been declared end-of-life on 2021-06-10. The last release in the series is 1.6.33. No further releases will be made by the community.</p> <p>Version 1.5 has been declared end-of-life on 2019-12-23. The last release in the series is 1.5.30. No further releases will be made by the community.</p> <p>Version 1.4 has been declared end-fo-life on 2017-09-16. The last release in the series is 1.4.42. No further releases will be made by the community.</p> <p>Version 1.3 has been declared end-of-life on 2015-12-23. The last release in the series is 1.3.47. No further releases will be made by the community.</p> <p>LedgerSMB versions 1.0, 1.1 and 1.2 won't be maintained any further due to the fact that there are some known security issues which can't be fixed.<!--break--></p> </div> <div class="field field--name-field-release field--type-entity-reference field--label-above"> <div class="field__label">Release</div> <div class="field__items"> <div class="field__item"><a href="/index.php/release/all-versions" hreflang="en">All Versions</a></div> <div class="field__item"><a href="/index.php/release/10" hreflang="en">1.0</a></div> <div class="field__item"><a href="/index.php/release/11" hreflang="en">1.1</a></div> <div class="field__item"><a href="/index.php/release/12" hreflang="en">1.2</a></div> <div class="field__item"><a href="/index.php/release/13" hreflang="en">1.3</a></div> <div class="field__item"><a href="/index.php/release/14" hreflang="en">1.4</a></div> <div class="field__item"><a href="/index.php/release/15" hreflang="en">1.5</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/142" hreflang="en">1.6</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/146" hreflang="en">1.7</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/147" hreflang="en">1.8</a></div> <div class="field__item"><a href="/index.php/taxonomy/term/149" hreflang="en">1.9</a></div> <div class="field__item"><a href="/index.php/release/20" hreflang="en">2.0</a></div> </div> </div> <div class="field field--name-field-faq-category field--type-entity-reference field--label-above"> <div class="field__label">FAQ Category</div> <div class="field__item"><a href="/index.php/faq-categories/support" hreflang="en">Support</a></div> </div> <div class="field field--name-field-topic field--type-entity-reference field--label-above"> <div class="field__label">Topic</div> <div class="field__items"> <div class="field__item"><a href="/index.php/topics/support" hreflang="en">Support</a></div> <div class="field__item"><a href="/index.php/topics/security" hreflang="en">Security</a></div> <div class="field__item"><a href="/index.php/topics/eol" hreflang="en">EOL</a></div> <div class="field__item"><a href="/index.php/topics/end-life" hreflang="en">End Of Life</a></div> </div> </div> <section class="field field--name-comment-node-faq field--type-comment field--label-hidden comment-wrapper"> </section> Sun, 30 Dec 2012 11:17:51 +0000 ehu 217 at https://ledgersmb.org Computer and Data Magic – North Carolina, USA https://ledgersmb.org/index.php/content/computer-and-data-magic-north-carolina-usa <span class="field field--name-title field--type-string field--label-hidden">Computer and Data Magic – North Carolina, USA</span> <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>We are an IT consultancy with specialties in Data Recovery and Linux administration. We've been using LSMB since 2017.</p> <p>We originally gave Intuit Quickbooks a try on the recommendation of our now ex-CPA. Quickbooks is a paid service/software, and yet getting useful help from them was PAINFUL if not impossible. Think long hold times, and poorly trained representatives. I hated literally every minute I spent on the phone with them! Doubly so when all they could seem to say after they finally came on the line and I yet again repeated the issue we were having for the nth time, was that they didn’t have any answers and/or that there was NO @#$% solution! It was enough to make me ask why we were paying them! Based on our experience, anyone who does any kind of business with Intuit is doing themselves a disservice. (Google it if you don't believe me)</p> <!--break--> <p>At the end of that year the CPA couldn't get any useful data out of our Quickbooks installation in spite of us following every procedure we were given. After much frustration and broken promises from Intuit, we migrated to LSMB, and only then could we generate the reports our CPA needed in order to file our taxes.</p> <p>We have found LSMB to be the most promising and easy to work with bookkeeping platform and community that we've had the privilege of working with. LSMB has enabled us to go fully paperless. Now we generate the needed paperwork for a given customer, they sign it electronically, and we simply attach the signed copy to their workorder. Everything stays organized. Gone are the days of emptying filing cabinets into boxes and loading said boxes into storage for the next 10 YEARS!</p> <h2>From a technical perspective</h2> <p>To be fair, I've been in the IT industry for more than 20 years, so I have a bit more experience with things like software maintenance and server administration than most. That said, once you get LSMB up and running, things should be fairly problem free, providing you follow IT standard best practices:</p> <p>1) Make frequent backups (for bookkeeping and POS software you should run a backup at least every night)<br /> 2) ONLY do software updates when you are able to afford the downtime caused by unexpected issues and have the time to correct them. Make a backup before you upgrade! We made a script to automate this on our installation, and so far have had no issues.</p> <p>LSMB is offered as a docker container. The use of docker enables the developers to spend their limited time and resources on making the software better rather than having to troubleshoot and try to make it work on all the possible different system configurations out there. If you have a working docker installation on your server, then things generally JustWork(tm).</p> <p>For our installation we used an Official LSMB docker container with a PostgreSQL docker container to sequester our accounting data away from the rest of the server and enable us to trivially backup our bookkeeping database from everything else and then restore it again without breaking anything else on the server should the need arise. Our backup and upgrade process is now accomplished via a single command, after which we login to our installation to make sure the update went smoothly. Our nightly backups are accomplished the same way.</p> <p>Aside from a fairly minor learning curve, LSMB has worked out well for us. The developers are super friendly and have cheerfully walked us through getting everything setup while answering our many how-do-I's along the way. These guys have been EXCELLENT to work with and very quick to help solve to any issues we’ve had. And lets not forget that LSMB actually GENERATED REPORTS OUR CPAs COULD USE!!!!</p> <p>– Josh Hefner<br /> Computer and Data Magic</p> </div> <span class="field field--name-uid field--type-entity-reference field--label-hidden"><span>ehu</span></span> <span class="field field--name-created field--type-created field--label-hidden">Tue, 05/11/2021 - 15:00</span> <div class="field field--name-field-industry field--type-entity-reference field--label-above"> <div class="field__label">Industry</div> <div class="field__item"><a href="/index.php/industry/services" hreflang="en">Services</a></div> </div> <section class="field field--name-comment-node-testimonial field--type-comment field--label-hidden comment-wrapper"> </section> Tue, 11 May 2021 22:00:01 +0000 ehu 519 at https://ledgersmb.org Technical documentation https://ledgersmb.org/index.php/content/technical-documentation <div class="node node--type-book node--view-mode-rss ds-1col clearfix"> <div class="field field--name-node-submitted-by field--type-ds field--label-hidden field__item">Submitted by <span>ehu</span> on Monday, July 9, 2012 - 11:26.</div> <div class="field field--name-node-changed-date field--type-ds field--label-inline clearfix"> <div class="field__label">Last modified</div> <div class="field__item">Monday, March 22, 2021 - 02:41</div> </div> <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>Next to the subsections of the technical documentation book on this site, the following documentation is available on related sites:</p> <ul> <li>The <a href="https://docs.ledgersmb.org/perl-api/">Perl API</a> documentation for all releases since 1.6.0</li> </ul> </div> <section class="field field--name-comment-node-book field--type-comment field--label-hidden comment-wrapper"> </section> </div> Mon, 09 Jul 2012 18:26:48 +0000 ehu 171 at https://ledgersmb.org