LedgerSMB 1.4 in beta testing period

I am very pleased to announce that LedgerSMB 1.4 has entered the beta testing period. While we expect to be continuing to move reports over to the new framework in this period, the codebase and database should be fairly stable at this point. If all goes well, within a few months, 1.4.0 will be released as a production-ready platform.

LedgerSMB 1.4 is positioned to be as large an improvement over LedgerSMB 1.3 as 1.3 was over 1.2. The pace of development has been very good and we have a large number of new features. Many of the changes we began working towards with 1.3 have become a lot more functional in 1.4. We now offer very basic customer relationship management, a web services framework, a CSV upload and export framework and more. Additionally our reporting routines have been centralized to make it easier for people to write reports for specific industries.

Here are a few highlights of what to expect:

  • Budget tracking and reporting is now included
  • There is a framework for managing payroll information and transactions
  • Very basic CRM features are provided.
  • New CSV import module allows for configurable uploads of bulk transactions and the like.
  • Departments and Projects may now be nested and extended to include other things like funds accounting.
  • Separation of duties is possible for invoices which include inventory items.

If anyone is interested in becoming a beta tester, or would like more information on what to expect, please join the devel- list or email me with questions.

Best Wishes,
Chris Travers

Comments

mikaelarhelger's picture

I am about to embark on LedgerSMB 1.3.34 (but have difficulties installing it). Shall I wait until LedgerSMB 1.4 comes out? If yes, will there be a Debian (Jessie) package with support for PostgreSQL 9.3?

Mikael Arhelger

Sorry for the delay on this.  This was in my follow-up queue for a while and then I got distracted.

In general unless you have specific needs of 1.4 features you are better off using 1.3.x.  If you are having trouble please ask for help on the email lists.  You will get more help there.  I also offer setup at a fixed rate as may others.

The specific features that might cause you to use 1.4 first would include batch processing of invoices, funds accounting, or a few other features.